
UNIT -I : Basics of Information Technology

CHAPTER - 1 : COMPUTER AND COMMUNICATION  
TECHNOLOGIES

TOPIC-1
Computer System

Quick Review
 ¾ Computer System : A computer is an electronic device which processes data based upon the instructions provided 
and generate the desired output.

 ¾ IPO Cycle : The basic principle on which the computer works.
 ¾ Computing Process: Input -> Process -> Output
 ¾ The characteristics of computer are Speed, Accuracy, Automation, Endurance, Versatility, Storage, Reduction of 
processing cost, and Intelligence quotient.

 ¾ CPU and processing system of computer:
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 ¾ Control unit is a link between memory unit and ALU (Arithmetical and Logical unit).
 ¾ Control Unit : The control unit controls and co-ordinates all the CPUs activities.
 ¾ Arithmetical / Logic Unit : This unit performs all the arithmetical and logical operations.
 ¾ Memory : This unit stores the data and instructions.
 ¾ RAM stands for ‘‘Random Access Memory’’. Every time you open a program, it gets loaded from the hard drive 
into the RAM. RAM is a very high-speed type of memory.

 ¾ ROM stands for ‘‘Read-Only Memory’’. ROM is a memory containing hardware instructions like BIOS and CMOS 
that the computer uses when it boots up, before the system software loads.

 ¾ External memory or storage device : These are portable devices to store data for future use.
 ¾ The hard disk is a spindle of magnetic disks, called plotters, that record and store information.
 ¾ Tape drive is a removable storage device mainly used for backing up data. It is similar to a Zip drive, but instead of 
Zip disks, it uses small tapes.

 ¾ I/O devices : The input and output devices attached to the computer like pen drive, memory chip.

TOPIC-2
Overview of Communication Technologies

Quick Review
 ¾ ICT stands for Information and Communication Technology.

 ¾ ICT links knowledge and education with computer and digital technology.
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 ¾ It mainly focuses on the use of audio-visual tools like computer, projector, speaker etc. to spread the knowledge.
 ¾ ICT benefited the students by giving more pictorial, video based and interactive learning.
 ¾ ICT has benefits in healthcare too. It helps doctors to talk about disease and treatment via video conferencing 
anywhere.

 ¾ ICT benefited patients to book appointments with hospitals or healthcare online and can download reports too.
 ¾ Using ICT, the people can use the government facilities filing the tax returns, applying for visa and passports etc.     
 ¾ ICT benefited government by keeping the transparency among the departments and thus keeping hold on the 
corruption among the people.

 ¾ Business also got benefited with ICT as the information now can be stored on external computer storage devices, 
different departments of the company can interact online, e-shopping emerged as a better tool to shop online.

 ¾ ICT in Design and Manufacturing helped the designers to make changes in design of the product easily.
 ¾ ICT helped manufacturers to produce goods of same design in quicker and easiest way.
 ¾ ICT also gave rise to some ethical threats to the society.
 ¾ Plagiarism is stealing another person’s ideas and passing them on as our own without giving credit to the owner/
author.

 ¾ Privacy is the ability of an individual or group to seclude themselves, or information about themselves, and thereby 
express themselves selectively.

 ¾ Internet privacy is the privacy and security level of personal data published via the internet. It is a broad term that 
refers to a variety of factors, techniques and technologies used to protect sensitive and private data, communications 
and preferences.

 ¾ A patent is an exclusive right granted by a country to the owner of an invention to make, use, manufacture and 
market the invention, provided the invention satisfies certain conditions stipulated in the law. Exclusive right 
implies that no one else can make, use, manufacture or market the invention without the consent of the patent 
holder. This right is available for a limited period of time.

 ¾ Copyright is a right, which is available for creating an original literary or dramatic or musical or artistic work. 
Cinematographic films including sound track and video films and recordings on discs, tapes, perforated roll or 
other devices are covered by copyrights.

 ¾ Data security can be defined as the protection of data against unauthorized access.
 ¾ A trademark is a distinctive sign, which identifies certain goods or services as those produced or provided by a 
specific person or enterprise.

 ¾ Hacking is gaining unauthorized access to data in a system or computer with the intention of harming the system 
or the owner.

 ¾ Cracking is somewhat similar to hacking, but difference is it is authorized access to check the protection of system 
by owner’s permission to protect the system from hackers.

 ¾ A sequence of characters that one must input to gain access to a file, application, or computer system, also called 
passkey.

 ¾ The process by which raw message information (plain text) is mapped or encrypted to a scrambled form (cipher text) 
before transmission or storage, then mapped back to its original form again (decrypted) when an authorized party 
wishes to read the plain text.

 ¾ Computer System Engineering, also called computer engineering, is a discipline that integrates several fields of 
electrical engineering and computer science required to develop computer systems.

 ¾ A web developer is responsible for programming the functionality of a website.
Careers in IT :
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CHAPTER - 2 : MEMORY AND I/O DEVICES

TOPIC-1
Memory and its units

Quick Review
 ¾ Memory is the internal storage area, which holds the data and instructions during the processing, and keeps it 
saved for future use. 

 ¾ Computer Memory is classified into two types :

      (i)  Primary Memory; also known as internal memory.

      (ii)  Secondary Memory; also known as external memory.

 ¾ Primary memory is the memory which holds the data required at the time of execution of the computer program 
(software). For example : RAM and ROM. RAM is volatile whether ROM is permanent type memory.

 ¾ Secondary memory is the memory in which data is stored so that it can be reinvoked in future purposes. It is non-
volatile in nature. For example : Pen drive, CDs, DVDs, hard disk, memory stick, etc.

 ¾ 1 byte = 8 bits.

 ¾ 1 Kilobyte = 1024 bytes.

 ¾ 1 Megabyte = 1024 Kilobytes.

 ¾ 1 Gigabyte = 1024 Megabyte.

 ¾ 1 Terabyte = 1024 Gigabyte.

TOPIC-2
Storage Devices

Quick Review
¾	Floppy disk is a flexible magnetic disk consisting of a circular plastic disk coated with magnetic oxide. This disk is 

used to store information and programs for future purpose.

¾	Hard disk is a thick little flat thing inside the computer, which can hold 100 times more information than the floppy 
disk. It is also used to store information and programs for future purpose.

¾	CD-ROM is a compact disc, which is used to store data. It provides read only access to large amount of data for 
future purposes.

¾	DVD is Digital Versatile Disc looks like CD but can store 4.7 GB data and faster than CD.

¾	Pen/Flash Drive : It is also called USB flash drive that works on plug and play principle. It is light weight, small, 
rewritable and portable device that can store up to 1 TB of data and faster than other external storage devices.

¾	Memory Stick is a digital data storage technology with up to 10 times the storage capacity of a 3·5 diskette. It is a 
removable flash memory card format.

¾	Memory card is a removable flash memory card storage device for recording digital photos. Many cameras come 
with a small amount of built-in storage and require the purchase of an extra memory card in order to hold large 
amount of photos.
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TOPIC-3
I/O Devices

Quick Review
¾	Input is the data or instructions fed to the computer.
¾	Output is the process of getting computerised result.
¾	Input unit is responsible for input phase i.e., it takes input from the user and forwards it for processing.
¾	Output unit is responsible for the output i.e., it makes available output after processing, to the users.
¾	VDU (Visual Display Unit) is a device that consists of display unit, a keyboard and a computer connection.
¾	Keyboard is an input device and an important part of the computer system.
¾	Mouse is an important input device mainly used in windows and other graphical software.
¾	Microphone is one of the most exciting areas of research in recognizing human voice or human speech so that this 

could be fed as input to the computer directly.
¾	Pointing device like Joystick is the input device used to point (position) on a specific part of screen and action with 

a button click. The pointer movement is done by ball movement on a rubber pad.
¾	Light pen is an input device to draw pictures on a special screen and read information from bar codes.
¾	MICR (Magnetic Ink Character Reader) is an input device specially used in banking industries to verify Cheques 

and Demand Drafts.
¾	OCR (Optical Character Reader) is a machine, which reads characters from a printed-paper to the computer.
¾	OMR(Optical Mark Reader) is an input device, which reads special symbols or marks. This device is commonly 

used in scholarship aptitude test or similar examinations.
¾	Digital cameras are very much like the still more familiar 35 mm film cameras.
¾	Scanner is an input device used to input copy of an image from paper to a computer.
¾	Barcode Reader : An input device used to read barcodes containing coded information about the product.
¾	Web Camera : An input device used to capture live images and videos and simultaneously transfer these to a 

computer.
¾	Printer is an output device, which is used to print text and graphics. Printers are of two types—impact and non-

impact.
¾	Impact printer is a printer that uses a device to process or strike ribbon to put a character.
¾	Non-impact printer prints without having a mechanism to strike against a sheet of paper or film.
¾	Plotter is a specialized output device designed to produce high quality graphics in a variety of colours.
¾	Speaker : An output device used to play sound from an audio or video file stored on a computer.

qq

CHAPTER - 3 : TYPES OF SOFTWARE

TOPIC-1
Computer System

Quick Review
 ¾ Program is a set of instructions, which are written to perform a specific task.
 ¾ Software is a set of programs which helps in performing various operations or direct the computer to process 
information.

 ¾ Software is mainly of two types—System software, Application software.
 ¾ The set of instructions, which co-ordinates the operations of the hardware, is called a system software.
 ¾ System software consists of all types of operating systems. In other words, system software are the software without 
which computer can not start, hence they are mandatory for the computer systems.

 ¾ Operating System : A type of system software that acts as an interface between the computer system along with 
attached devices and the user. For example : Windows, Linux, Macintosh, etc.

 ¾ The set of instructions or programs, which are designed for specific uses or applications, is called as application 
software.

 ¾ Application software is of two types—general purpose application software and specific purpose application 
software.
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TOPIC-2
General  Purpose Application Software

Quick Review
¾	Word Processing Software is used to enter, format, edit and print text documents.
¾	Spreadsheet Software is used to enter data in forms of tables and performs mathematical operations on the data.
¾	Presentation software is used to present information in graphical and attractive formats on digital slides for better 

understanding by the viewer.
¾	Programs written only for specific purpose are called specific software programs.
¾	Accounting programs, attendance programs, payroll programs, etc. are specific software programs.
¾	Database management system (DBMS) is a software system that uses a standard method of cataloging, retrieving 

and running queries on data. The DBMS manages incoming data, organizes it, and provides ways for the data to 
be modified or extracted by users or other program.

TOPIC-3
Utility Software

Quick Review
¾	A utility program carries out some of the command tasks needed when using a computer.
¾	Disk Management : A build in tool of Windows to manage hard disk partitions without rebooting or interrupting 

the system.
¾	File/Folder Management : This utility software of windows help to manage, copy, move, rename, delete, recover 

and monitor the files and folders present on the computer.
¾	Virus Scanner/Cleaner is also known as Antivirus which scans the device to keep it safe from any virus attack. It 

either deletes the virus or deactivates the virus.
¾	Encryption is the conversion of data into a form, called a cipher text, which cannot be easily understood by 

unauthorized people.
¾	Decryption is the process of converting encrypted data back into its original form, so that it can be understood.

qq

CHAPTER - 4 : OPERATING SYSTEM

TOPIC-1
Introduction with Operating Systems

Quick Review
 ¾ Operating system can be defined as the software bridge which acts as interface between user and the computer 
hardware. Example: Windows, Unix, Boss, Lynux, Android etc.

 ¾ Loading up of OS files into computer’s memory is called booting up.

 ¾ Operating System is required for smooth interaction with computers, initiating computer operations automatically, 
accessing various hardware devices, computer memory management and overall security of the computer 
programs.

 ¾ The functions of OS include, storing and accessing data (storage management), scheduling execution of programs 
(process management), allocates memory for various processes (memory management) and exchanging data and 
files between multiple users (extended machine management)

 ¾ Based on user interaction operating systems are divided into two types :

        1.  CUI(Command User Interface)

        2.  GUI(Graphical User Interface)
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 ¾ Real Time OS : An operating system that provides quick and accurate output with in a prescribed time limit.

 ¾ Distributed OS : An operating system that is used to manage a distributed system, that is, many computer and 
hardware devices which are independent of each other.

 ¾ Multiprogram OS : The OS that allows CPU to execute more than one program at the same time.

 ¾ Multiprocessing OS : The OS that allows a computer having many CPUs to execute more than one program at 
the same time.

 ¾ UNIX : Unix OS controls a computer using CUI, which in turn runs an application that provides GUI to easily 
interact with the computer. It is multiuser and multitasking OS.

 ¾ LINUX : It is Unix like operating system mainly used on servers and mainframe computers as well as supercomputers.

 ¾ Windows : It is GUI based OS having dominance in desktops and laptops.

 ¾ Solaris : It is Unix based OS developed by Sun Microsystems and mainly used on servers for hosting websites.

 ¾ BOSS Linux is the Indian made operating system. Its latest version is 6.0(Anoop), released in August 2015.

 ¾ Mobile OS Android : It is Linux based Open source mobile OS mainly designed for touch screen devices like smart 
phones and tablets.

qq

CHAPTER - 5 : NETWORKING AND MULTIMEDIA

TOPIC-1
Computer Networking

Quick Review
¾	A group of computers and peripheral devices connected to each other is called a network.
¾	Networking is a concept of implementing tools and tasks for linking computers so that they can share resources 

over the network.
¾	Internet is called network of networks that connects millions of computers.
¾	InterSpace : A program that allows more than one users to communicate with each other online in three dimensional 

environments.
¾	A protocol is a set of rules that the computer uses to communicate with each other across a network.
¾	LAN is a network within a single building or linking of up to a 5 Kms in size. It is acronym for Local Area Network.
¾	MAN spans a larger geographical area between 10 Km and 100 Km, often a city. It is acronym for Metropolitan Area 

Network.
¾	WAN spans wide area often across the metropolitans and countries. It is an acronym for Wide Area Network.
¾	A hub is used in a wired network to connect ethernet cables from a number of devices.
¾	A router is a device in computer networking that forwards data packets to their destinations based on their 

addresses.
¾	Wired Networking Tools : They are also called guided media that uses cables like twisted pair, coaxial cable, 

ethernet cable, optical fiber to connect computers.
¾	The most common form of wiring in data communication applications is the twisted pair cable.
¾	For long distance communication, microwave radio transmission is widely used as an alternative to co-axial cable.
¾	A co-axial cable consists of one conductor usually a small copper tube, a wire within and insulated from another 

conductor of large diameter usually copper tubing or copper braid. 
¾	Ethernet Cable : The network cable used for high speed connection between network devices like modem, routers 

etc of LANs and MANs.
¾	Wireless Networking Tools : They are also called unguided media that uses waves instead of cables to transfer data 

between computers. For example: Bluetooth, Infrared, Wi-Fi for short distance communication and Microwaves, 
Radio waves and Satellite for long distance communication.

¾	Satellite : The satellite transmission of data uses a satellite antenna on earth and uses microwaves to transfer the 
data between satellite and the stations on the earth.
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TOPIC-2
Multimedia and Social Sites

Quick Review
¾	Convergence is an approach towards a common view. It can be felt in the field of telecommunication, computing & 

entertainment, etc. Convergence literally means the combination of different forms of electronic technology, such 
as data processing and word processing converging into information processing.

¾	Content is information that may provide value to the end user in the form of specific knowledge or context.
¾	Raw facts and figures is data.
¾	Information is processed data.
¾	Multimedia is the combination of several media and contents such as audio, video text, etc. Multimedia finds its 

application in various areas such as : industry, commercial, entertainment and fine arts, education, engineering 
industry, mathematical and scientific research, medicine.

¾	Components of multimedia are capture devices, storage devices, communication networks, computer system, 
display devices.

¾	Pixel is invented from the word picture element.
¾	Electronic images are of two types : raster image and vector image.
¾	Raster file formats are : BMP, PCX, TIFF, JPEG, GIF, PNG, PSD, CPT.
¾	Vector file formats are : EPS, WMF, AI, CDR, SVG PLT, CGM.
¾	An audio file format stores audio data on a computer system e.g., MIDI, WAV.

qq

UNIT -II : CYBER-SAFETY

CHAPTER - 6 : CYBER SECURITY

Quick Review
¾	In the eighties when the internet was in its infancy, its main usage came from university students and professors in 

an atmosphere of implicit trust. This means that security was not the first thing in mind when the basic uses and 
functions of the internet were first developed. 

¾	Nowadays the internet is everywhere both in public and in private life. It has become a vital means for professional 
and personal - often confidential - communication. This has required security enhancements to be added to the 
various communication methods used on the internet after it became widely used.

¾	Safe Internet Browsing Tips :
l	 Install and use most secure Internet Browser like (Google Chrome, Mozilla Firefox).
l	 Customise your security settings like ( shutting off features like “auto fill”, turning off “cookies”, block pop-up 

windows)
l	 Create typical password which cannot be recognized by others.
l	 Hide your IP (Internet Protocol) with a VPN (Virtual Private Network)
l	 Download software from trusted sources.
l	 Use Anti-Virus protection
l	 Be prompt about updating your operating system and software
l	 Don’t use unsecure WiFi.
l	 Back up your data.

¾	Tips to stay safe on social media :
l	 Use a strong password.  The longer it is, the more secure it will be.
l	 Use a different password for each of your social media accounts.
l	 Set up your security answers.
l If you have social media apps on your phone, protect your device with strong password.
l Be selective with friend requests. If you don’t know the person, don’t accept their request.  It could be a fake 

account.
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l Be careful about what you share. Don’t reveal sensitive personal information i.e. home address, financial 

information, phone number.  
l Become familiar with the privacy policies of the social media channels you use and customize your privacy 

settings to control who sees what.
l Protect your computer by installing antivirus software to safeguard.  Also ensure that your browser, operating 

system, and software are kept up to date.
l Remember to log off when you’re done.

¾	“Malware” is short for malicious software and used as a single term to refer to virus, spy ware, worm etc. Malware 
is designed to cause damage to a stand-alone computer or a net worked PC. So wherever a malware term is used it 
means a program which is designed to damage your computer it may be a virus, worm or Trojan horse.

¾	Virus is a program written to enter to your computer and damage/alter your files/data. A virus might corrupt or 
delete data on your computer. Viruses can also replicate themselves.

¾	Worms are malicious programs that make copies of themselves again and again on the local drive, network shares, 
etc. The only purpose of the worm is to reproduce itself again and again.

¾	A Trojan horse is not a virus. It is a destructive program that looks as a genuine application. Unlike viruses, Trojan 
horses do not replicate themselves but they can be just as destructive. Trojans also open a backdoor entry to 
your computer which gives malicious users/programs access to your system, allowing confidential and personal 
information to be theft.

qq

UNIT -III : OFFICE TOOLS

CHAPTER - 7 : WORD PROCESSOR

Quick Review
 ¾ A word processor is a package that processes textual data and creates organised and flawless documents.
 ¾ Word processing is the process of typing, editing, and formatting, etc., of words and paragraphs.
 ¾ MS-Word is a word processor, comes in MS office package by Microsoft Corporation.
 ¾ MS-Office is an integrated software package developed by Microsoft Corporation of USA.
 ¾ The writer is the word processing software package. is OpenOffice.org.
 ¾ The horizontal text alignment can be left, right, centered or justified.
 ¾ Tables can be inserted in MS-Word documents.
 ¾ To split cells, select table > split cells.
 ¾ To apply formula, use insert option.
 ¾ To insert cells/row columns > insert menu.
 ¾ To apply mathematical formula / expression, use insert menu.
 ¾ The character formatting is concerned about making decisions regarding the fonts and font sizes, text attribute 
(B/I/U) and text positioning (super-script/sub-script) etc.

 ¾ The dialog box is a special window which comes after executing a command. This box contains several actions to 
be taken by typing or clicking.

 ¾ Cursor is the small blinking line on the document, which indicates your position on the screen.
 ¾ The first and default OpenOffice.org Writer file name is Untitled-1.
 ¾ Formatting is to give special effects to the text like change in font, style, size and colors, etc.
 ¾ Selection is to highlight text for format, cut, copy, or delete purposes.
 ¾ Clipboard is the temporary area in the memory, which stores cut or copied text.
 ¾ When selected text is cut, it is sent to clipboard, which can be later placed into document.
 ¾ De Select the text by clicking anywhere outside the selection on the page or press an arrow key on the keyboard.
 ¾ At any point of time, we want to keep the default setting, press (Ctrl + M or click Default Formatting from Format 
menu).

 ¾ Ruler is used to set tabs, indents and margins for a document.
 ¾ Margin refers to the distance from the text to the paper edge.
 ¾ The tab is a specified stop on horizontal ruler used to jump after pressing tab key.
 ¾ Line spacing is the vertical distance between lines of text.
 ¾ When you make a line spacing change, it affects only the text in a paragraph that contains the insertion point.
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 ¾ Print layout view is the best used view when working with normal word processing including, text, table and 
graphics.

 ¾ Web layout view is best used when creating a page for the web. In this view, you can see the background, text is 
wrapped to fit the window, and images appear as they would online.

 ¾ Print layout view is best used when our document contains things like images, headers and footers, columns, etc. 
Each of these components will be visible.

 ¾ Using print feature of Writer, you can take hard copy of your document.
 ¾ Page preview shows how a file will look when we print it.
 ¾ If a correction is made using AutoCorrect option, and the same mistake is repeated again while typing the 
document, it will be corrected automatically.

 ¾ OpenOffice.org Writer contains a built-in dictionary that gets used when Spell check is performed.
 ¾ Mail merging is an powerful and important feature of MS-Word.
 ¾ Main document is the writer document which contains letter that remain the same for each version of the merged 
document.

 ¾ A data source is database containing name address etc.
 ¾ To perform mail merge, follow the following steps :

 l Prepare the main document.
 l Insert the variable field.
 l Create the data source.
 l Merge the letter and data.

 ¾ Track change help in format data source.

qq

CHAPTER - 8 : PRESENTATION TOOL

Quick Review
 ¾ Power Point is presentation software in MS Office package of Microsoft Corporation.
 ¾ To start PowerPoint select Start > Programs > Microsoft PowerPoint.
 ¾ Slide is working area in the presentation software to create, format and modify the content to be appearing on the 
screen.

 ¾ Slide show is an animated presentation that we display on a computer monitor or projection system.
 ¾ A slide transition is a special effect used to introduce a slide during a slide show.
 ¾ Slide transitions are the effects that take place when one slide gives way to the next one in the presentation, like 
Roll down from top or Fly in from left.

 ¾ You can add transitions while in Slide Sorter view or in Normal view.
 ¾ Custom animation effect sets up the way you want the text or an object to appear on your slide during a slide show 
presentation.

 ¾ To modify the styles used in any slide master, press F11 key to open the Styles and Formatting windows.
 ¾ Interactions are things that happen when you click on an object in a slide.
 ¾ Slide animations are similar to transitions, but they are applied to individual elements on a single slide.
 ¾ The three ways to create a new presentation are : Blank presentation, Design template and Auto content wizard.
 ¾ To open a presentation Click File > Open.
 ¾ Design template contains ready made formatting and color but not same slide style.
 ¾ The text can be either typed in placeholders or in text box.
 ¾ You may format the text by changing point, font size, aligning the text, adding bullet or number, shadow, etc.
 ¾ To insert a New Slide, select Insert > New Slide.
 ¾ To insert a clipart, select a Slide Layout with Clip Art.
 ¾ To insert a table, select a Slide Layout with table.
 ¾ Normal view has three working areas outline tab, slides tab; notes pane and show pane.
 ¾ Slide Sorter view helps to view your slides in thumbnail form.
 ¾ You may rearrange the slide using slide sorter view.
 ¾ Slide Show View takes the full computer screen as it would be in an actual slide show presentation.
 ¾ To save a file select File > Save.
 ¾ To exit PowerPoint, select File > Exit.
 ¾ To insert a sound clip, select Insert > Movies and Sounds.
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 ¾ Do not insert two sound clips to be played automatically as you will not be able to play even one sound properly.
 ¾ To insert a video clip, select Insert > Movies and Sounds.
 ¾ To fix a formatting style for all the slides in a presentation, select View > Slide Master.
 ¾ You can insert charts and organization charts in the presentation.
 ¾ To animate text and graphics, select Slide Show > Custom Animation.
 ¾ To apply transitions and timing, select Slide Show > Slide Transition.
 ¾ To print a file, select File > Print.
 ¾ Slide contains placeholder to hold different types of contents.
 ¾ Slide put together make-up your presentation.
 ¾ Normal view displays single slide, outline of presentation and speaker notes area.
 ¾ There are two ways to place a slide in the slide design area of the normal view : clicking the slide thumbnail in the 
slides pane or using the navigator.

 ¾ Outline view displays slide menu and main text.
 ¾ Outline view contains all of the slides of the presentation in their numbered sequence. Only the text in each slide 
is shown. Slide names are not included.

 ¾ Slide sorter view displays miniature of each slide.
 ¾ The slide sorter view contains all of the slide thumbnails. Use this view of work with a group of slides or with only 
one slide.

 ¾ “Handout view is for setting up the layout of your slides for a printed handout.
 ¾ Form template uses a template design already created as the basis for a new presentation.
 ¾ A Slide Master is a slide with a specified set of characteristics which is used as the beginning point for creating other 
slides.

 ¾ A slide master has a defined set of characteristics, including the background color, graphic, or gradient, objects 
(such as logos, decorative lines and other graphics) in the background, headers and footers, placement and size of 
text frames, and the formatting of text.

 ¾ Master slides, slide master and master page-all refer to a slide that is used to create other slides.
 ¾ Slide masters have two types of styles associated with them : presentation styles and graphics styles.
 ¾ Presentation styles affect three elements of a slide master: the background, background objects (such as icons, 
decorative lines and text frames), and the text placed on the slide.

 ¾ Background can be applied to a number of elements in impress : the page, a default text area, a graphic object and 
so on.

 ¾ Note area is an area in normal view where speaker notes can be entered.

qq

CHAPTER - 9 : EXCEL SPREADSHEET

Quick Review
 ¾ A worksheet is a collection of cells where we keep and manipulate the data. By default, each Excel workbook 
contains by default three worksheets.

 ¾ The worksheet in excel is termed as spreadsheet.
 ¾ MS-Excel is a powerful component of a MS-Office and powerful spreadsheet software package by Microsoft 
Corporation.

 ¾ A cell is the intersection of a row and a column.
 ¾ In Excel, formula enables us to calculate the results based on the numbers.
 ¾ A worksheet in MS-Excel contains 256 columns and 65,536 rows.
 ¾ To start MS-Excel, select Start > Programs > Microsoft Office > Microsoft Excel.
 ¾ To open a workbook, select File > Open.
 ¾ Components of MS-Excel are Title bar, Menu bar, Standard toolbar, formatting toolbar, Formula bar, Standard 
toolbar.

 ¾ To save a workbook, select File > Save.
 ¾ To close a workbook, select File > Close.
 ¾ To exit Excel, select File > Exit.
 ¾ To activate a cell, double click on it.
 ¾ You can name a range by selecting a range and type its name in name box.
 ¾ The Undo command allows you to undo your last 16 actions.
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 ¾ The default height of a cell is 12.75 points and column width is 8.43 points.
 ¾ AutoFill feature is used to fill the cells with a predefined series of numbers and text.
 ¾ You can format cell by selecting Format > Cells.
 ¾ You can apply border or pattern to a selected cell or range of cells.
 ¾ You can insert or delete a worksheet.
 ¾ Excel offers ready formulae and functions for calculations.
 ¾ A formula always begins with equal to sign (=).
 ¾ To copy formula, select Edit > Copy and to paste a formula, select Edit > Paste.
 ¾ Relative reference adjusts the cell reference of the same formula to perform the same relative operation.
 ¾ Absolute reference is the cell reference that is not changed when a formula is copied.
 ¾ Mixed reference is a combination of absolute and relative reference.
 ¾ AutoSum feature add the values above or left to the target or destination cell.
 ¾ If a function starts the formula, an equal to (=) sign will be required before function name also.
 ¾ Cell address is the column row number given to a cell by which it is referred.
 ¾ Workbook is a collection of worksheet.
 ¾ Range is a contiguous or non-contiguous blocks of cells.
 ¾ AutoFill allows to quickly enter predefined series of data.
 ¾ Autocomplete feature of excel automatically input data in the active cell if it’s a repeated entry in the column.
 ¾ Function is a built-in formula in Excel.
 ¾ Constant is a number entered directly into Formula and whose value does not change.
 ¾ Reference indicates excel to the location of information you want to use in a formula.

qq

UNIT -IV : SCRATCH OR PYTHON

CHAPTER - 10 : REVIEW OF PYTHON

TOPIC-1
Python Basics

Quick Review
¾ Python was created by Guido van Rossum late in 1980 at National Research Institute in the Netherlands. Python 

got its name from a BBC comedy series – “Monty Python’s Flying Circus”. 
¾ Interactive Mode: Interactive mode, as the name suggests, allows us to interact with OS.
¾ Script Mode: In script mode, we type Python program in a file and then use interpreter to execute the content of 

the file.
¾ Indentation: Blocks of code are denoted by line indentation, which is rigidly enforced.
¾ Comments: A hash sign (#) that is not inside a string literal begins a single line comment. We can use triple quoted 

string for giving multiple-line comments.
¾ Variables: A variable in Python is defined through assignment. There is no concept of declaring a variable outside 

of that assignment.
¾ Dynamic Typing: In Python, while the value that a variable points to has a type, the variable itself has no strict 

type in its definition.
¾ Multiple Assignment: Python allows you to assign a single value to several variables simultaneously. 
 For example: a = b = c = 1

   a, b, c = 1, 2, “john”
¾ An identifier is a name used to identify a variable, function, class, module, or other object. An identifier starts with 

a letter A to Z or a to z or an underscore ( _ ) followed by zero or more letters, underscores, and digits (0 to 9).
¾ Identifiers :  Python does not allow punctuation characters such as @, $, and % within identifiers. Python is a case 

sensitive programming language. Thus, Value and value are two different identifiers in Python.
 Here are following identifier naming convention for Python :

 l Class names start with an uppercase letter and all other identifiers with a lowercase letter.

 l Starting an identifier with a single leading underscore indicates by convention that the identifier is meant to be 
private.
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 l Starting an identifier with two leading underscores indicates a strongly private identifier.

 l If the identifier also ends with two trailing underscores, the identifier is a language-defined special name.
¾ Reserved Words(Keywords) :  The following list shows the reserved words in Python

and del from whilenot

as elif global withor

assert else if yieldpass

break except import print

class exec in raise

continue finally is return

def for lambda try

¾ Python Keyword List
 These reserved words may not be used as constant or variable or any other identifier names. All the Python key-

words contain lowercase letters only.
¾ Data Types : Data type is a set of values and the allowable operations on those values. Python has a great set of 

useful data types. Python’s data types are built in the core of the language. They are easy to use and straight for-
ward.

DATA TYPES

NUMBERS SEQUENCES SETS MAPS

int long float complex string list tuple dictionary

 ¾ Numbers can be either integers or floating point numbers.
 ¾ A sequence is an ordered collection of items, indexed by integers starting from 0. Sequences can be grouped 

into  

  strings, tuples and lists.

   l Strings are lines of text that can contain any character. They can be declared with single or double quotes.

   l Lists are used to group other data.  They are similar to arrays.
   l A tuple consists of a number of values separated by commas.
  ¾	A set is an unordered collection with no duplicate items.
 ¾	A dictionary is an unordered set of key value pairs where the keys are unique. 

¾  Operator : Operators are special symbols which perform some computation. Operators and operands form an 
expression. Python operators can be classified as given below :

 

Operators

Arithmetic
operators

Relational
operators

Logical
operators

Assignment
operators

Bitwise
operators

Membership
operators

+
–

/
%
**
//

¹

<
>
<=
>=
!=or<>
=

or
and
not

=
+=
– =
*=
/=
%=
//=
**=

&
|
^
-
<<
>>

in
not in
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¾  Python operator types

¾  Functions in Python : A function is a block of statements that perform a computation. The lines of code inside a 

function are executed sequentially.

Functions

Built-in Modules User-dfined

¾  Functions : Module of the program to do specified task.

¾  Built-in functions: Built-in functions are the functions that are built into Python and can be accessed by a pro-

grammer.

¾  Modules: A module is a file containing Python definitions and statements. We need to import modules to use any 
containing part before separator, separator parameter and part after the separator if the separator parameter is 
found in the string of its function or variable in our code.

¾  User–Defined Functions : We can also create our own functions. Parameters are the values provided in the paren-
thesis in the function header when we define the function. Arguments are the values provided in function call/ 
invoke statement.

¾ Function Arguments: You can call a function by using the following types of formal arguments:

¾ Required arguments
¾ Keyword arguments
¾ Default arguments

¾ Variable-length arguments

¾ String: In Python, consecutive sequence of characters is known as a string. An individual character in a string is 
accessed using a subscript (index).

¾ List: Like a string, list is a sequence of values. List can be of any type. Lists are the simplest data structure in Py-
thon and are used to store a list of values. Lists are collections of items (strings, integers, or even other lists). Each 
item in the list has an assigned index value. Lists are enclosed in [ ]. Each item in a list is separated by a comma. 
Unlike strings, lists are mutable, which means they can be changed.

¾ Dictionaries: A dictionary is like a list. In a list, index value is an integer, while in a dictionary index value can be 
any other data type and are called keys. A dictionary is like a list, but more in general. In a list, index value is an 
integer, while in a dictionary index value can be any other data type and are called keys.

¾ Tuples: A tuple is a sequence of values, which can be of any type and they are indexed by integer.

qq

CHAPTER - 11 : LISTS MANIPULATION AND IMPLE-
MENTATION

Quick Review
¾ A data structure is a named group of data of different data types which can be processed as a single unit.

¾ Queues are FIFO lists where insertion take place at REAR end and deletion take place at FRONT end.

¾ Stacks are LIFO lists where insertion and deletions take place at one end referred as TOP. 

¾ Some important sorting algorithms are Bubble sort, Insertion sort and selection sort.

¾ Some applications of stacks are :

 > Expression evaluation

 > String Reversal

 > Memory management

¾ Circular queues are the queues implemented in circular form rather than a straight line.
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¾ Date structure : A group of data which can be processed as a single unit.

                             

Simple

Structure Non-linear

Compound

Data Structure

Array Linear

Stack TreeQueue GraphLinked
list

¾ Array: A set of contiguous data of similar data type. Python lists are actually arrays of variable length and have 
elements of different data types.

¾ Sequential allocation of memory : Elements stored in sequence of their declaration.
¾ Traversal : To move in a list in a sequential manner starting from first element to the last element.
 Insertion of a new element in a sorted list has to be inserted at an appropriate position so that it falls in order with 

the other elements of the list.

qq


