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COMMON QUARTERLY EXAMINATION – SEPTEMBER 2018 

XII – STANDARD 
COMPUTER SCIENCE ANSWER KEY 

SECTION-I 
1. a) 12 
2. a) Delete 
3. b) Insert column 
4. d) Ruler 
5. a) F2 
6. b) Auto fill 
7. c) Label 
8. c) Master page 
9. b) Navigator 
10.  d) Abstraction 
11.  d) Void 
12.  a) >> 
13.  a) Return 
14.  b) 0 
15.  a) strcmp 

SECTION-II 

16. Text Editing: 
 Entering a new text or modifying the existing text in a document is known as text editing. 
 Copy, Cut, Paste and Find and Replace are some of the commonly used editing functions. 

17. Generate series:  33, 30, 27, ……………..3? 

1. Select the range of cells. 
2. Choose Edit →Fill → Series to get Fill Series dialog box. 
3. Select Liner Type. 
4. Select Direction as Right. 
5. Enter 33 as Start value. 
6. Enter 3 as End value. 
7. Enter -3 as Increment value and click ok button. 

18.  Query: 

 
19.  Uses of morphing: 
 Morphing is a technique by which we can blend two or more images to form a new image. 
 Most modern multimedia applications, particularly games, combine these techniques with 

virtual reality to create an environment in which gives the viewer the feeling that he is part of 
that environment. 

 Once the animations are created it can be enhanced using morphing. 
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20. Customize a presentation: 

1. We can create as many as custom slides shows as we want. 
2. Star office Impress allows us to star slide shows from the current slide. 
3. We can hide/show the slides during a slide show. 
4. We can define the right rehearse timings for automatic slide changes. 

21. Encapsulation: 

The Mechanism by which the data and functions are bound together within an object 
definition is called as Encapsulation.  

22. Association in C++: 

Operators are executed in the order of precedence. The operands and the operators are 
grouped in a specific logical way for evaluation. This logical grouping is called as 
association.   EX: a *= 2 ( a = a * 2) 
 

23. Advantages of Functions: 

 Reduce the size of the program 
 Induce reusability of code 
 A function can be shared by other programs by compiling it separately and loading them together.  

 
24.  Declare 2D Array: 
 A two dimensional array is an array in which each elements is itself an array.  

 

SECTION-III 

25.  Add a word in autocorrect list: 
 If the error and its correction are to be added to the Auto Correct list the following command 

is used Tools → AutoCorrect, now auto correct dialog box appears on the screen. 
 In this box, with the Replace tab selected the word to be replaced is typed in the Replace text 

box and the replacement word in the With text box. 
 When the same mistake is made StarOffice Writer will automatically replace the misspelled word 

with the correct spelling. 
26.  Date arithmetic : 

Manual date calculations can be tricky because we have to keep track of number of days in 
months. 
In spreadsheets, date calculations become very simple. Here the user can add a number to a date 
and arrive at a new date, find the difference between two dates and use a wide variety of functions 
and formats to get what are required. 
 

27.  Filter: 
 A filter is also a type of query. It is also used to select and display records which match a certain 

condition. The remaining records are hidden from the user. 
 Thus to ‘filter’ database data base records means to select and display records which match a 

certain condition.  
Two types of filters. 

I. Auto Filter   II. Default Filter. 
 

http://www.trbtnpsc.com/2017/10/11th-quarterly-exam-question-papers-and-answer-keys-download.html
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do 
{ 
action block; 
} 
while (condition); 

 

for(intial value ; test-condition ; increment) 
{ 
action block; 

} 

 

28. Record shows rehearse timing: 
 Open a presentation, and switch to Normal View. 
 Start the show with the Rehearse Timings from Slide Show menu. You see the first slide and 

a timer in the bottom left corner. 
 When it is time to advance to the next slide, click the timer. Continue for all slides in your 

presentation. 
 Star Office has recorded the display time for each slide. 
 If you want the whole presentation to auto-repeat, open the menu Slide Show → Slide Show 

Settings. A window appears on the screen. 
 Select Auto and then click OK. 

29. Order of an Expression: (b xb) – (4 x a x c) 

2b-4ac     (or)     b2-4ac 

30.  Syntax: 

if(condition / expression) 
{ 
action block 1; 
} 
else 
{ 
action block 2; 
} 

31.  Call by  value and call by reference : 

Call by value: 
 In this method, the called function creates new variables to store the value of the arguments 

passed to it. 
 This method copies the values of actual parameters into the formal parameters, thus the 
 function creates its own copy of arguments and then uses them. 
 “In call by value method, any change made in the formal parameter is not reflected back to the 

actual parameter.” 
Call by reference: 
 In this method, the called function arguments-formal parameters become alias to the actual 

parameters in the calling function. 
 The function is working with its own arguments. 
 It is actually working on the original data. 

 

32.  int x[3] [2]={0, 1, 2, 3, 4, 5} 

Answer: X [1][1]=3 
X [2][0]=4 

 
33. Class member assessed: 

 

 0 1 
0 0 1 
1 2 3 
2 4 5 
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SECTION-IV 

34.  Spell check: 
Checking the Spelling after the Document is Typed 
The following steps are used for a spell check. 
 Tools → Spelling → Check is selected or icon is clicked. To check a part of the document 

only that portion is selected. 
 The F7 key may also be pressed to select the spelling command. 

 
 Not in dictionary text area displays the 

misspelled word and the Suggestions list 
displays any alternative spellings. 

 
Any of the following can be done: 
 To skip this occurrence but stop on the next 

one. Ignore Once button is clicked. To skip 
all occurrences of this word. Ignore All 
button is clicked. 

 To replace the word with one of the selected spellings, in the suggestions list that spelling is 
clicked, and Change button is clicked to change this occurrence and Change All button is 
clicked to replace all occurrences of the world. 

 If none of the replacements is correct, correction can be made manually in the Not in 
dictionary text area. Add button is clicked to add the word to the dictionary.  

 

(Or) 
Indent a text: 

Indenting Text with the Toolbar 

 If a left indent is required - useful for setting off a paragraph from the main body text - the toolbar 
can be used to set the indent. 

 Click the Increase Indent  icon; the paragraph is indented 1/2 inch from the left margin. The 
button again can be clicked to increase the indent. 

 Each time the button is clicked, the paragraph is indented another 1/2 inch. 
 If the indent is too much or if one wants to undo the indent, the Decrease Indent  icon is 

clicked to decrease of undo the indents. 
 
Indenting Text with the Paragraph Dialog Box 
 
1. Move the insertion point to the beginning of the paragraph to be indented. To indent several 
paragraphs, select those paragraphs. 
2. Select Format → Paragraph command. Now paragraph dialog box appears on the screen. 
3. Click the Indents & Spacing tab in the Paragraph dialog box 
4. Do any of the following. 

 To indent from the left, type the amount to be indented in the Before text spin box or use 
the spin arrows to select a value. 

 To indent from the right, type the amount to be indented in the After text spin box or use 
the spin arrows to select a value.  

 Click the OK button. 
 The First line option can be used to indent the line of the paragraph. Using the spin arrows, if 

a positive value is specified, the first line will be indented. 
 A negative value will result in a hanging indent; that is, the first line will hang outside the 

paragraph. 
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35. Functions in worksheet: 

Using Functions: 
 StarOffice Calc has a wide variety of functions that allow you to perform several frequently 

done calculations. 
 Functions are predefined formulae that are available in StarOffice Calc. 

 

To insert a function: 

 To select a function, go to Insert menu and Select the Function option. The Function Wizard 
dialog box appears. 

 A list of all functions is displayed in the Function box when All is selected in the Category box. 

 
To select a function: 
 Select the category in the Category box. 
 Scroll down the list to find the function you want. Click 

once on the function 
 name to see a short description of that function on the 

right side of the window. 
 Double – click on it to insert it into the worksheet. 
 

 fx  The Function Wizard shortcut icon on the formula 
bar can also be used to select and insert functions. 

For example, 
 To insert the SQRT function, place the cursor in the cell where you want to insert the function and 

click on the Function Wizard icon. 
 Select Mathematical from Category. 
 Select the SQRT function from the list of functions, which appears by double clicking on it. 
 Enter the number 64. When you click on OK, the result is displayed in the cell in the worksheet is 8. 

 Σ  One of the most commonly used function is the Sum function. This function calculates the 
sum of a given set of numbers. 

(Or) 
Insert Empty cell, roe and column in calc: 

Click the Insert Cell from View → Toolbar menu. 
 A floating toolbar with four icons appears.  
 These icons are,  

o Insert Cells Down 

o  Insert Cells Right  

o Insert Rows 

o  Insert Columns  
 

Insert Cells Down: 
 In order to insert an empty cell in a column and move the existing cells down, place the  

cursor in the cell where you want to insert the new cell and click on the Insert Cells Down 
icon. 

 For example, in the Marks worksheet, to insert a cell in D4 and move the contents of the cell 
D4:D7 down, select D4 and click the icon. 

 
Insert Cells Right 
 In order to shift the content of a cell to the right and to create an empty cell, select the cell and 

click the Insert Cells Right icon. 
 For example, suppose that the data in the fifth row of the Marks  orksheet has to be shifted 

from C5-F5 to D5-G5. To do so, select the cell C5 and click the icon. 
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Insert Columns 
 In order to insert a column, select the column where you want to insert and click the Insert 

Columns icon.  
 For example, to insert a new column between E and F in the Marks worksheet, select the 

column F and click the icon. 
 
Insert Rows 
 In order to insert an empty row in a worksheet, select the row where you want to insert the 

new row and click the Insert Rows icon.  
 For example, if you want to insert a new row between rows 4 and 5 in the Marks worksheet  

select the row 5 and click the icon.  
 
 

 
36.  Classification database: 

    Database Types: 

Based on the conceptual structures, the databases can be classified as follows: 
1. Flat – File database 
2. Relational database 
3. Hierarchical database 
4. Network database 
5. Object-Oriented database 

 
Flat – File Database 
 A database file that consists of a single data table is a Flat-file database. 
 Flat-file database can be quite useful for certain single user or small-group situations, 

especially for maintaining lists such as address lists or inventories. 
 Data that is stored, managed, and manipulated in spreadsheet is another example of a flat-file 

database. 
 
Relational database 
 A relational structure represents a database made up of a set of related tables. 
 In a relational database, one or more common fields existing in two or more tables create a 

relationship between these tables. The common field or fields are called the Keys. 
 A primary key is a key that uniquely identifies a record in a database table. 
 In relational databases, a primary key can consist of one or more fields. 
 The relational database structure is the most prevalent database in today’s business 

organizations. 
Hierarchical database 
 

 The hierarchical database structures were primarily used on Main Frame computers. 
 In hierarchical databases, records are organized in a tree like structure by type. 
 The relationship between record types is said to be a parent-child relationship, in which any 

child type relates only to a single parent type. 
 
Network database 
 

 The Network database is very similar to the hierarchical structure except that any one record 
type can relate to any number of other record types. 

 
Object Oriented database 
 

 An Object Oriented database is a newer structure that has been generating a great deal of 
interest in recent years. 

 The object oriented structure groups data items and their associated characteristics, attributes, 
and procedures into complex items called objects. 

 An object is defined by its characteristics, attributes and procedures. 
 A procedure refers to the processing or handling that can be associated to the object. 
 

(Or) 
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Form design: 

A form: 

A form is simply a screen that displays the fields of a record in a well-spaced out manner. 
A form can be associated with a single table or with multiple tables. 

 
To design a form in Star Base, follow the procedure given below: 
 
1. Select Form icon from the <Database> pane and then select ‘Use Wizard to Create Form’. 

 
2. Select the table or query for which the form is to be designed. The field names of the selected 

table or query are displayed in the ‘Available fields’ text area. 
 
3. Select the field names that you would like to include in the form using the > or >> button and then 

click the Next button. 
 

4. Next, StarOffice Base displays ‘Set up a subform’ window. Select the ‘Add Subform’ 
checkbox, if you want to insert another form with within this form else click Next. The Style 
icons show you how the form will look if it is selected. Click on the Style icon and click on the 
Next button. 

 

5. The next window to selecting the data entry mode. Click on the radio button to choose whether 
       the form is to be used only for entering new data or to be used for displaying all data. 

6. The next window Form Wizard – Apply Styles specifies the form style. The page style decides 
the font attributes like font type, size color and background of the text in the form. The Field 
border specifies the field border style for the form. 
 

7. Next, Set the name of the form window appears asking for a name for the form. Type the            
name of the form and click the Finish button. 
 

37. Entry control loop: 
1. While Loop    
2. For Loop 

 
1. While loop: 

 
 While loop is also called as entry check loop. The body of the while loop will be executed only if 

the test expression results true placed in the while statement. 
 

 The control exits the loop once the test expression evaluated to false.  
 

Syntax:- 
while (condition) 
{  
action block; 
}  

Example: 
#include<iostream.h> 
#include<conio.h> 
main() 
{ 
clrscr(); 
int n=2; 
while(n<6) 
{ 
cout<<n*n<< “\t”; 
n=n + 1; 
} 
getch(); 
} 
 

OUTPUT: 
4  9  16  25  
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2. for (; ; ) .. loop: 

 
 for (; ; ) loop is an entry controlled loop. It is used when an action is to be repeated for a 

predetermined number of times. 
 The body of the for loop is executed only if the test expression results is true placed in the for 

statement. 
 The control exits the loop once the test expression evaluated to false. 

 
Syntax: 

for(intial value ; test-condition ; increment) 
{ 
action block; 
} 

 The body of the loop has one or more statement. The blocking with braces are needed only if 
the contains two or more statements. 

 
Example: 

#include<iostream.h> 
#include<conio.h> 
void main() 
{ 
clrscr(); 
int i; 
for(i=0; i<5; i++) 
{ 
cout<< i << “\n”; 
} 
getch(); 
} 

(Or) 
Types of parameters passing functions: 

1. Call by value method: 
 
 In this method, the called function creates new variables to store the value of the arguments 

passed to it. 
 

 This method copies the values of actual parameters into the formal parameters, thus the 
function creates its own copy of arguments and then uses them. 
 

 “In call by value method, any change made in the formal parameter is not reflected back to 
the actual parameter.” 
 

 In this method, the called function creates new variable to store the value of the arguments 
passed to it. 

Example: 
 

#include<iostream.h> 
#include<conio.h> 
void sawp(int n1,int n2) 
{ 
int temp; 
temp=n1; 
n1=n2; 
n2=temp; 
cout<<n1<<’\t’<<n2<<’\n’; 
} 
main() 

OUTPUT: 
0 
1 
2 
3 
4 
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{ 
int m1=10,m2=20; 
clrscr(); 
cout<< “Before swap”<<m1<<’\t’<<m2<<’\n’; 
cout<< “Calling swap\n”; 
swap(m1,m2); 
cout<< “Back to main values are”<<m1<<’\t’<<m2<<’\t’; 
getch(); 
} 

 
2. Call by reference method: 

In this method, the called function arguments-formal parameters become alias to the actual parameters 
in the calling function. 

 The function is working with its own arguments. 
 It is actually working on the original data. 
 In this method, any change made in the formal parameter is reflected back in the actual 

parameter. 
 
Example:  

#include<iostream.h> 

#include<conio.h> 

void sawp(int &n1,int &n2) 

{ 

int temp; 

temp=n1; 

n1=n2; 

n2=temp; 

cout<<n1<<’\t’<<n2<<’\n’; 

} 

main() 

{ 

int m1=10,m2=20; 

clrscr(); 

cout<< “Before swap”<<m1<<’\t’<<m2<<’\n’; 

cout<< “Calling swap\n”; 

swap(m1,m2); 

cout<< “Back to main values are”<<m1<<’\t’<<m2<<’\t’; 

getch();  

} 
 
  

OUTPUT: 
 

Before swap 10  20 

Calling swap 

20  10 

Back to main values are 10  20 

OUTPUT: 
 

Before swap 10  20 

Calling swap 

20  10 

Back to main values are 10 20 
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38. Output of the Program: 

 

1 
2 
3 
4 
5 
Value of the variable i after executing the while loop…. 5 
Sum……15 

 
 (Or) 

Write the program: [ C++ Program - Reverse Array ] 
 
# include <iostream.h> 
# include <conio.h> 
void main ( ) 
int even [10] = {1, 2, 3, 4, 5, 6, 7, 8, 9, 10}; int reverse [10]; 
for (int i=0, int j = 9; i<10; i++, j —) 
reverse [j] = even [i]; 
clrscr ( ); 
for (i=0; i<10, i++) 
cout<< ‘\t’ << even [i] << ‘\t’ << reverse [i] << ‘\n’; 
getch ( ); 
} 
Output : 
 

1 10 
2 9 
3 8 
4 7 
5 6 
6 5 
7 4 
8 3 
9 2 
10 1 

************ 
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