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PART-II
Answer any six question in which question no.22 is compulsory
16.What is meant by Text Editing?
Entering a new text or modifying the existing text in a document is known as text
editing.

17.What are the various types of paragraph alignment?
v’ Left Align Text.

v Right Align Text
v Justify Text.
v’ Center Text.

18. What is use of auto correction Option?

StarOffice Writer will automatically correct some spelling mistakes. StarOffice Writer
recognises some common misspellings and typographical mistakes and makes the
replacement automatically. For instance, if aword is typed as “teh”, StarOffice Writer
automatically replaces this with the correct
word “the”.

19.Name the popular spreadsheet software in starcalc

> Excel from Microsoft Corporation

» Quattro Pro from Borland International, *
» Improve’ from Lotus Corporation and

» StarOffice Calc’ from Sun Microsystems.




20.What is the difference between Query and Filter?

Query Filter

1. Queries can be saved. 1. Filter cannot be saved.
2. Queries are user constructed 2. Filter is also a type of query.
statements.

21.What is compression? Explain its two types?
Compression is technique by which a recurring set of information is identified and

replaced by a single piece of information.

22. Write the C++ equivalent expression using the conditional operator where.
F=0.5 if x=30, otherwise f=5

Ans:- f=(x==30)?0.5:5;

23. What are the different types of Inheritance?
There are 5 types of inheritance in C++. They are
v" Single inheritance

v Multiple inheritance
v Multilevel inheritance
v" Hybrid inheritance

v" Hierarchical inheritance
24. What is use of Call Centers?

A call center is sometimes defined as a telephone based shared services center for
specific customer activities and are used for number of customer information transfer,
advice, technical support and so on.

Part-111
Answer any six question in which question no.32 is compulsory

25.How will you change the Row and Column Width ?
+ To resize a column, place the cursor in a table cell, hold down Alt and Press left or
right arrow.
¢+ To resize a column without changing the width of the table, hold down Alt+Ctrl, and
then
press the left or right arrows
26.How will you insert page number in the Footer area?

1) Footer is an area of bottom of the page.
i) Click in the header or footer area.

i) Clicking on Insert->Fields->Page Number will insert page number on every
page.




27.What is Range ?Given example.
Range: A continuous group of cells in a worksheet is called a Range. Range
Address: A Range address is the address of the first cell in the range, followed by a
colon followed by address of the last cell in the range. Ex: A1:A10

28.What is Reference Operators in Star Office Calc? Given example.

> Reference operator combine cell areas.
» . and ! are the reference operators in star office calc.

Operator Name Example

: (Colon) ! (Exclamation) Range Intersection Al:A5 =sum(A1:A5!B1:B5)

29.What is a Report ? What are its types?

v" Report is a printed information on the paper.
v" We may generate any desired report, from the data of the database
The are two types

I)Static ii) Dynamic

30.What is meant by Rehearse Timing?

Star Office assists you in defining the right rehearse timings for automatic slide
changes. Star Office records the display the time for each slide, So the next time you play

the show with automatically slide changes the timing will be as recorded

31. What is encapsulation?
The mechanism by which the data and functions are bound together with in an object

definition is called as encapsulation.

32.Ans:-
Switch(x)
{
Casel:
Cout<< “One’;
Break;
Case2:
Cout<< “two”
Break;
2
33.What is meant by thef of computer time
Idle time of computers in an organization is being stolen illegally. Some other
software runs on an idle computer without the knowledge of the organization. This is called
theft of computer time.




PART-IV
34.Given the steps involved in fine d and Replacing a given text in a star office writer

documents?

To Find and Replace Text
1. Choose Edit->Find & Replace. The Find &Replace dialog box appears.

2. In the Search for box, type the text that you want to find in your document.
3. In the Replace with box, enter the replacement word or phrase.
4. Click Find to start the search.

5. To replace the found instance of the text with what you entered in the Replace with box, click
Replace. To replace all instances of the text with what you entered in the replace with box, click
Replace All.

6. To skip the found text and to continue the search, click Find.
7. Click Close when you have finished the search
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(OR)
How would carry out the spell check after the entire document is typed?
1. Tools>Spelling>Check is selected or the F7 key may also be pressed to select the
spelling command. Or
icon is clicked. The Spell check dialog box appeared.

2. Not in dictionary text area displays the misspelled word and the Suggestions list displays any
alternative spellings.

3. To skip this occurrence but stop on the next one Ignore Once button is clicked. To skip all
occurrences of this word Ignore All button is clicked.

4. To replace the word one of the selected spellings, in the suggestions list that spelling is clicked
and Change button is clicked. To change this occurrence and Change All button clicked to replace
all occurrences of the word.




5. If none of the replacements is correct, correction can be made manually in the Not in dictionary
text area. Add button is clicked to add the word to the dictionary.

35.Draw and explain the various icons available Table formatting tool bar in star

office documents
The function of each icon in the toolbar is indicated below:

= Table Fixed

=1 - Table Fixed, Proportional

= - Table, Variable

= - Merge Cells - This icon is used to combine two or more cell into a single cell.

# - Split Cells - This icon is used to split a cell into two or more cells.

£ - Optimise - Clicking on this icon displays a pop up menu with options

like Space columns equally, Space rows equally, Optimum row height
and Optimum column width.
& - Insert Row - This icon is used to insert a row below the current row.
= - Insert Column - This icon inserts a column to the right of the current
column.
= - Delete Row - This icon deletes the current row from the table.
= - Delete Column - This icon deletes the current Column from the table.

0~ _ Borders - This icon displays a floating toolbar with different border
option for the table.

IF . Line Style - This icon is used to choose the style of line to be used for
the border.

™~ _Border Colour - Clicking on this icon displays a palette of colours that
can be used as a border colour for the table.
(OR)
How will insert chart in a work sheet?
One of the most popular features of star office calc software the ability to generate charts based on

numeric data. The purpose of charts is to visually present the data for easy understanding.
1. Select the data you want to chart.

2. Click on Insert=>Chart or Click on the Insert Chart icon.

3. The cursor becomes a + sign with small picture of the graph. Place this cursor where you want to
insert the chart and click. The Autoformat Chart window appeared.

4. It prompts you enter the area in the worksheet to be charted and click Next.

5. The next window, which appeared and displays the different types of charts that can be created

along with a preview of each. Select the type of chart in which you want to present the data. Click
on Next.

6. For each type of the chart there are different formats available. Here select the desired format.
Click on Next.




7. In the next window, you have provisions to give Title for the chart, Titles for X and Y axes and
legends.

8. Click Create. Now chart will be created in your worksheet.
36. Explain the various types of Data Base.
1) Flat-File database
2) Relational database
3) Hierarchical database
4) Network database
5) Object-oriented database
1. Flat-File Database:
A database file that consists of a single data table is a Flat-File database. Data that stored, managed
and manipulated in spreadsheet is another example of a flat-file database. Ex: Spreadsheet
2. Relational Database:
A relational structure represents a database made up of a set of related tables. In a relational
database one or more common fields existing in two or more tables create a relationship between
these tables. The common field of fields are called the keys. A primary key is a key that uniquely
identifies a record in a database table. The relational database structures is the most prevent
database in today*s business organizations.
3. Hierarchical database:
The hierarchical database structures were primarily used on Main Frame computers. In
hierarchical databases, records are organized in a tree like structure by type. The relationship
between record is said to be a parent-child relationship, in which any child type relates only to a
single parent type.
4. Network Database:
The network database is very similar to the hierarchical structure except that any one record type
can relate to any number of other record types.
5. Object Oriented Database:
¢ An Object oriented database is a newer structure that has been generating a great deal of
interest in recent types.
%+ The object oriented structure groups data items and their associated characteristics, attributes
and procedures into complex items called as Objects.
% An object is defined by its characteristics, attributes and procedures. An objects characteristics
can be text, sound, video. Examples of attributes might be color, size, and style. A procedure refers
to the processing or handling that can be associated to the object.
(OR)

Explain scope rules of variable?
Scope refers to the accessibility of a variable.

. Local scope

. Function scope

. File Scope

. Class Scope

. Local Scope:

. A local variable is defined within a block.

. The scope of a local variable is the block in which it is defined.

. A local variable cannot be accessed from outside the block of its declaration.




4. Local variables are not known outside their own code block. A block of code begins and ends
with curly braces { }.

5. Local variables exist only while the block of code in which they are declared is executed.

2. Function Scope:

The scope of variables declared within a function is executed to the function block, and all sub
blocks there in. The life time of a function scope variable is the life time of the function block. The
scope of formal parameters is function scope.

3. File Scope:

A variable declared I above all blocks and functions above main( ) ahs to the scope of file. The
scope of a file scope variable is the entire program. The lifetime of a file scope variable is lifetime
of a program.

Example:

#include<iostream.h>

#include<conio.h>

int a=10;

File scope void main()

{

int a=4,b=7;

L

int c;

Function Scope c=a+b;
cout<<c; Local Scope

}
}

4. Class Scope:

1. The members that have been declared as private can be accessed only from within the class.
2. The members that have been declared as protected can be accessed from within the class, and the
members of the inherited classes.

3. The members that have been declared as public can be accessed from outside the class also.
Class class_name

{

private:

variable declaration;

function declaration;

protected:

variable declaration;

function declaration;

public:

variable declaration;

function declaration;
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37.Explain the nested -if statement with example




Definition:

1. The statement sequence of if or else may contain another if statement. The If...Else
statement can be nested within another.

2. In an nested if....... else statement, “Each else matches with the nearest unmatched

preceding if”. The general syntax is
if(condition)

if(condition)

{

action block-1;

}

else

{

action block-2;

}

else

{

action block-3;

}

Example Program:
#include<iostream.h>
#include<conio.h>
void main()

{

intml,m2;
cout<<”Enter the values of m1 and m2”;
cin>>mi1>>m2;
if(m1>70)

if(m2>70)

{

cout<<”Pass”;

}

else

{

cout<<”Fail”;

}

else

{

cout<<"Try to get pass”;
}

getch();

}
(OR)

Write the rules for Operator Overloading in c++?




1. Only existing operators can be overloaded. New operators cannot be created.
2. The overloaded operator must have at least one operand of user defined type.

3. The basic definition of an operator cannot be replaced or in other words on cannot
redefine the function of an operator. One can give additional functions to an operator.

4. Overload operators behave in the same way as the basic operators in terms of their
operands.

5. When binary operators are overloaded, the left hand object must be an object of the
relevant class.

6. Binary operators overloaded through a member function take one explicit argument
38.0ut put the program

HELLO

Value of Aand B

The two integer are 10 20
The sumis 30

The multiply is 200

38 B

ERROR CORRECTION

#include<iostram.h> #include<iostream.h>

Private; private:

Public public:

PROTECT: Protect;

); )2

Class A; public b; Class A: public b

Public: public:

int b1;b2;b3 int b1,b2,b3;

Curley brace missing }

Void() Void main()

Der:a3=0; Der.a3(0);

A3:fun(); A3.fun();
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